hive-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Zoltan Haindrich (JIRA)" <>
Subject [jira] [Created] (HIVE-14289) can't reliably specify hadoop.version for maven build
Date Tue, 19 Jul 2016 21:41:20 GMT
Zoltan Haindrich created HIVE-14289:

             Summary: can't reliably specify hadoop.version for maven build
                 Key: HIVE-14289
             Project: Hive
          Issue Type: Bug
         Environment: maven 3.3.9
            Reporter: Zoltan Haindrich

if someone would like to build against a different hadoop.version; it looks straightforward
to use {{-Dhadoop.version=...}}. however this doesn't "fully" override the default value of
the {{hadoop.version}} maven property.

steps to reproduce:
  * change hadoop.version to some nonsence:
sed -i "/hadoop.version.*hadoop.version/s|.*|<hadoop.version>nonexistentt</hadoop.version>|"
 * specify a valid {{hadoop.version}} from the commandline:
mvn clean package -DskipTests -Dhadoop.version=2.6.1

i'm not sure..but from {{-X}} output i've seen:
[DEBUG] Ant property 'hadoop.version=2.6.1' clashs with an existing Maven property, SKIPPING
this Ant pr
operty propagation.

the build will fail..or at least it fails for me..

This message was sent by Atlassian JIRA

View raw message