hive-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Thejas Nair <thejas.n...@gmail.com>
Subject Re: Running unit tests?
Date Fri, 06 May 2016 00:33:47 GMT
Does this work from base hive directory ? (runs a specific test )
mvn clean  install -DskipTests  && cd itests/ &&  mvn  test
-Dtest=TestCliDriver '-Dqfile=index_compact_2.q'

On Wed, May 4, 2016 at 10:54 AM, Ravi Prakash <ravihadoop@gmail.com> wrote:
> Hi!
>
> Could someone please tell me how to run the clientpositive/clientnegative
> itests/qtest tests ? This document :
> https://cwiki.apache.org/confluence/display/Hive/HiveDeveloperFAQ#HiveDeveloperFAQ-HowdoIruntheclientpositive/clientnegativeunittests?
> mentions running ant package as the first step, but I don't see a build.xml
> in the root directory, itests directory or qtests.
>
> When I run the maven commands (cd itests/qtest;mvn test -Dtest=TestCliDriver
> )
>
> I get this error:
>
> Tests run: 1, Failures: 0, Errors: 1, Skipped: 0, Time elapsed: 0.558 sec
> <<< FAILURE! - in org.apache.hadoop.hive.cli.TestCliDriver
> initializationError(org.apache.hadoop.hive.cli.TestCliDriver)  Time
> elapsed: 0.006 sec  <<< ERROR!
> java.lang.NoClassDefFoundError:
> org/apache/hadoop/hbase/zookeeper/MiniZooKeeperCluster
>     at java.net.URLClassLoader.findClass(URLClassLoader.java:381)
>     at java.lang.ClassLoader.loadClass(ClassLoader.java:424)
>     at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:331)
>     at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
>     at
> org.apache.hadoop.hive.ql.QTestUtil$QTestSetup.preTest(QTestUtil.java:1722)
>     at org.apache.hadoop.hive.ql.QTestUtil.<init>(QTestUtil.java:425)
>     at
> org.apache.hadoop.hive.cli.TestCliDriver.<clinit>(TestCliDriver.java:53)
>
> Could you please update the documentation for the latest source?
>
> Thanks
> Ravi

Mime
View raw message