hive-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "kulkarni.swarnim@gmail.com" <kulkarni.swar...@gmail.com>
Subject [DISCUSS] Hive and HBase dependency
Date Wed, 12 Aug 2015 15:43:24 GMT
Hi all,

It seems like our current dependency on HBase is a little fuzzy to say the
least. And with increased features relying on HBase(HBase integration,
HBase metastore etc), I think it would be worth giving a thought into how
we want to manage this dependency. I have also seen regressions[1][2] come
up recently due to this dependency not managed properly. Plus we need to
think about moving to HBase 1.0 soon as well to take advantage of the
backwards compatibility guarantees that HBase is providing.

Our current HBase dependency is 0.98.9. Also with out current bifurcation
of branches to create a 1.x branch for stability and 2.x for bleeding edge,
I propose that we still keep the version to 0.98.9 on the 1.x branch and
move to HBase 1.0 in our 2.0 branch. In that way we can start taking
advantage of the latest updates to the HBase API in our 2.x branch and
still keep 1.x backwards compatible by avoiding a direct jump to HBase 1.0.
If we decide to go this route, we might need to revert back some of the
compatibility breaking changes[2] that sneaked into 1.x and move them over
to 2.x.

Thoughts?

Thanks,
Swarnim


[1] https://issues.apache.org/jira/browse/HIVE-10990
[2] https://issues.apache.org/jira/browse/HIVE-8898

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message