hive-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Patrick McAnneny (JIRA)" <j...@apache.org>
Subject [jira] [Created] (HIVE-10837) Running large queries (inserts) fails and crashes hiveserver2
Date Wed, 27 May 2015 21:13:20 GMT
Patrick McAnneny created HIVE-10837:
---------------------------------------

             Summary: Running large queries (inserts) fails and crashes hiveserver2
                 Key: HIVE-10837
                 URL: https://issues.apache.org/jira/browse/HIVE-10837
             Project: Hive
          Issue Type: Bug
         Environment: Hive 1.1.0 on RHEL with Cloudera (cdh5.4.0)
            Reporter: Patrick McAnneny
            Priority: Critical


When running a large insert statement through beeline or pyhs2, a thrift error is returned
and hiveserver2 crashes.

I ran into this with large insert statements -- my initial failing query was around 6million
characters. After further testing however it seems like the failure threshold is based on
number of inserted rows rather than the query's size in characters. My testing shows the failure
threshold between 199,000 and 230,000 inserted rows.

The thrift error is as follows:

Error: org.apache.thrift.transport.TTransportException: java.net.SocketException: Broken pipe
(state=08S01,code=0)


Also note for anyone that tests this issue - when testing different queries I ran into https://issues.apache.org/jira/browse/HIVE-10836




--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message