hive-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Owen O'Malley" <omal...@apache.org>
Subject Re: Do we still support hadoop-1.2.x API (-Phadoop-1)?
Date Wed, 29 Apr 2015 02:58:06 GMT
On Tue, Apr 28, 2015 at 5:25 PM, Szehon Ho <szehon@cloudera.com> wrote:

> Hadoop 2 has been GA for a little over a year, there is still a fairly
> significant user base that uses hadoop-1 and would not be happy with this
> change.


The question isn't whether there are people running Hadoop 1.x, it is
whether those people are likely to install a new version of Hive running on
their old Hadoop cluster. As a point of reference, CDH 4 shipped Hadoop 2.0
and Hive 0.10 and HDP 2.0 shipped Hadoop 2.0 and Hive 0.12.


> Perhaps we can declare it deprecated in some future release (perhaps 1.3),
> then another release to formally remove it, as was done in HBase.


Are you interested in managing a Hadoop 1.x compatible version of Hive?
Maybe we should call the new release Hive 2.0 and enable you to maintain
the Hive 1.x branch with backwards compatibility with Hadoop 1.x. That
would enable the rest of the Hive community to move forward and take
advantage of the powerful new features in Hadoop 2.x.

.. Owen

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message