hive-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sergio Pena" <sergio.p...@cloudera.com>
Subject Re: Review Request 29961: HIVE-9302 Beeline add jar local to client
Date Tue, 03 Feb 2015 23:18:41 GMT

-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/29961/#review70845
-----------------------------------------------------------



beeline/src/java/org/apache/hive/beeline/ClassNameCompleter.java
<https://reviews.apache.org/r/29961/#comment116284>

    Should we create a function like isClassFile(name) as well?



beeline/src/java/org/apache/hive/beeline/ClassNameCompleter.java
<https://reviews.apache.org/r/29961/#comment116285>

    Nobody is using this class. Should we make it private instead?



beeline/src/java/org/apache/hive/beeline/Commands.java
<https://reviews.apache.org/r/29961/#comment116286>

    Add an space between ){



beeline/src/java/org/apache/hive/beeline/Commands.java
<https://reviews.apache.org/r/29961/#comment116287>

    If we are not doing anything special with these exceptions, then I think we could catch
a generic exception 'Exception e' instead.



beeline/src/java/org/apache/hive/beeline/DatabaseConnection.java
<https://reviews.apache.org/r/29961/#comment116290>

    Add a space between (, ), {, }



beeline/src/java/org/apache/hive/beeline/DatabaseConnection.java
<https://reviews.apache.org/r/29961/#comment116291>

    If we are not doing anything special with these exceptions, then I think we could
      catch a generic exception 'Exception e' instead.



beeline/src/main/resources/BeeLine.properties
<https://reviews.apache.org/r/29961/#comment116292>

    Did you mean to write this?
    
    help-addlocaldrivername: Add driver name that needs to be supported in the beeline client
side.



beeline/src/test/org/apache/hive/beeline/TestBeelineArgParsing.java
<https://reviews.apache.org/r/29961/#comment116293>

    Could you use a better name for this?



beeline/src/test/org/apache/hive/beeline/TestBeelineArgParsing.java
<https://reviews.apache.org/r/29961/#comment116294>

    Could you use a better name for cnnStr?



beeline/src/test/org/apache/hive/beeline/TestBeelineArgParsing.java
<https://reviews.apache.org/r/29961/#comment116295>

    Does this need to run 'addlocaldriverjar' instead of 'addlocaldrivername' ?


- Sergio Pena


On Ene. 26, 2015, 2:57 a.m., cheng xu wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/29961/
> -----------------------------------------------------------
> 
> (Updated Ene. 26, 2015, 2:57 a.m.)
> 
> 
> Review request for hive, Brock Noland, Dong Chen, and Sergio Pena.
> 
> 
> Repository: hive-git
> 
> 
> Description
> -------
> 
> Support adding local driver jar file in the beeline side and add unit test for it
> 
> 
> Diffs
> -----
> 
>   LICENSE c973c36 
>   beeline/src/java/org/apache/hive/beeline/BeeLine.java 630ead4 
>   beeline/src/java/org/apache/hive/beeline/ClassNameCompleter.java 065eab4 
>   beeline/src/java/org/apache/hive/beeline/Commands.java 291adba 
>   beeline/src/java/org/apache/hive/beeline/DatabaseConnection.java 8ba0232 
>   beeline/src/main/resources/BeeLine.properties d038d46 
>   beeline/src/test/org/apache/hive/beeline/TestBeelineArgParsing.java a6ee93a 
>   beeline/src/test/resources/DummyDriver-1.0-SNAPSHOT.jar PRE-CREATION 
>   beeline/src/test/resources/postgresql-9.3.jdbc3.jar PRE-CREATION 
> 
> Diff: https://reviews.apache.org/r/29961/diff/
> 
> 
> Testing
> -------
> 
> Manullay test done.
> Newly added test passed.
> 
> 
> Thanks,
> 
> cheng xu
> 
>


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message