hive-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mohit Sabharwal (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HIVE-9309) schematool fails on Postgres 8.1
Date Wed, 14 Jan 2015 22:07:36 GMT

    [ https://issues.apache.org/jira/browse/HIVE-9309?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14277779#comment-14277779
] 

Mohit Sabharwal commented on HIVE-9309:
---------------------------------------

Yes, we need to document the {{-dbOpts}} argument. And also add {{postgres.filter.81}} as
the (only) valid value for this argument.

To the "The schematool Command" section, we need to add:
{code}
 -dbOpts <databaseOpts>             Backend DB specific options
{code}

As well as need another section, like:
{code}
The dbOpts is optional and can be set to:
 postgres.filter.81 : Postgres upgrade scripts contain "set standard_conforming_strings" command,
which is not applicable for Postgress 8.1. Using this option will skip this command and, hence,
prevent upgrade from failing. 
{code}

Thank you, [~leftylev] !

> schematool fails on Postgres 8.1
> --------------------------------
>
>                 Key: HIVE-9309
>                 URL: https://issues.apache.org/jira/browse/HIVE-9309
>             Project: Hive
>          Issue Type: Bug
>          Components: Database/Schema
>            Reporter: Mohit Sabharwal
>            Assignee: Mohit Sabharwal
>             Fix For: 0.15.0
>
>         Attachments: HIVE-9309.patch
>
>
> Postgres upgrade scripts set {{standard_conforming_strings}} which is not allowed in
8.1:
> {code}
> ERROR: parameter "standard_conforming_strings" cannot be changed (state=55P02,code=0)
> {code}
> Postgres [8.1 Release notes|http://www.postgresql.org/docs/8.2/static/release-8-1.html]
say that "standard_conforming_strings value is read-only"
> Postgres [8.2 notes|http://www.postgresql.org/docs/8.2/static/release-8-2.html] say that
it can be set at runtime.
> It'd be nice to address this for those still using Postgres 8.1
> This patch provides a schemaTool db option "postgres.filter.81" which, if set, filters
out the "standard_conforming_strings" statement from upgrade scripts.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message