hive-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hive QA (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HIVE-9299) Reuse Configuration in AvroSerdeUtils
Date Thu, 08 Jan 2015 06:44:34 GMT

    [ https://issues.apache.org/jira/browse/HIVE-9299?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14268903#comment-14268903
] 

Hive QA commented on HIVE-9299:
-------------------------------



{color:red}Overall{color}: -1 at least one tests failed

Here are the results of testing the latest attachment:
https://issues.apache.org/jira/secure/attachment/12690643/HIVE-9299.patch

{color:red}ERROR:{color} -1 due to 2 failed/errored test(s), 6732 tests executed
*Failed tests:*
{noformat}
org.apache.hadoop.hive.cli.TestMiniTezCliDriver.testCliDriver_optimize_nullscan
org.apache.hadoop.hive.cli.TestMinimrCliDriver.testCliDriver_schemeAuthority
{noformat}

Test results: http://ec2-174-129-184-35.compute-1.amazonaws.com/jenkins/job/PreCommit-HIVE-TRUNK-Build/2285/testReport
Console output: http://ec2-174-129-184-35.compute-1.amazonaws.com/jenkins/job/PreCommit-HIVE-TRUNK-Build/2285/console
Test logs: http://ec2-174-129-184-35.compute-1.amazonaws.com/logs/PreCommit-HIVE-TRUNK-Build-2285/

Messages:
{noformat}
Executing org.apache.hive.ptest.execution.PrepPhase
Executing org.apache.hive.ptest.execution.ExecutionPhase
Executing org.apache.hive.ptest.execution.ReportingPhase
Tests exited with: TestsFailedException: 2 tests failed
{noformat}

This message is automatically generated.

ATTACHMENT ID: 12690643 - PreCommit-HIVE-TRUNK-Build

> Reuse Configuration in AvroSerdeUtils
> -------------------------------------
>
>                 Key: HIVE-9299
>                 URL: https://issues.apache.org/jira/browse/HIVE-9299
>             Project: Hive
>          Issue Type: Bug
>          Components: Serializers/Deserializers
>    Affects Versions: 0.14.0, 0.13.1, 0.15.0
>            Reporter: Nitay Joffe
>            Assignee: Nitay Joffe
>             Fix For: 0.15.0
>
>         Attachments: HIVE-9299.patch
>
>
> I am getting an issue where the original Configuration has some parameters needed to
read the remote Avro schema (specifically S3 keys).
> Doing new Configuration doesn't pick it up because the keys are not on the classpath.
> We should reuse the Configuration already present in callers.
> I'm using Hive/Avro from Spark so it'd be nice if we could put this into Hive 0.13 since
that's what Spark's built against.
> See also https://github.com/jghoman/haivvreo/pull/30



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message