hive-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Chengxiang Li (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HIVE-9212) Several plugin version in modules is not consistent with others.
Date Wed, 24 Dec 2014 07:47:13 GMT

    [ https://issues.apache.org/jira/browse/HIVE-9212?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14258082#comment-14258082
] 

Chengxiang Li commented on HIVE-9212:
-------------------------------------

A compile case:
maven.compiler.plugin.version is set to 3.1 in $HIVE_HOME/pom.xml, but in $HIVE_HOME/ql/pom.xml,
 maven-compiler-plugin's version for profile hadoop-1 is set to 2.3.2 directly.
While Hive code has some uncompatible issue, we may get some similiar error as below if build
hive with profile hadoop-1:
{noformat}
[ERROR] Failed to execute goal org.apache.maven.plugins:maven-compiler-plugin:2.3.2:compile
(default-compile) on project hive-exec: Compilation failure
[ERROR] /home/cxli/sources/github/chengxiangli/hive/ql/src/java/org/apache/hadoop/hive/ql/exec/persistence/MapJoinTableContainerSerDe.java:[122,22]
error: cannot find symbol
[ERROR] -> [Help 1]
[ERROR] 
[ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
[ERROR] Re-run Maven using the -X switch to enable full debug logging.
{noformat} 

The error message is unclear, without any information about what symbol is missed. This is
a maven-compiler-plugin issue([MCOMPILER-158|http://jira.codehaus.org/browse/MCOMPILER-158])
which has been resolved in 3.1. Keep all plugin version consistent with central configured
properties would prevent us maintain them seperately, and may avoid issues like above.

> Several plugin version in modules is not consistent with others.
> ----------------------------------------------------------------
>
>                 Key: HIVE-9212
>                 URL: https://issues.apache.org/jira/browse/HIVE-9212
>             Project: Hive
>          Issue Type: Improvement
>          Components: Build Infrastructure
>    Affects Versions: 0.14.0
>            Reporter: Chengxiang Li
>            Assignee: Chengxiang Li
>            Priority: Minor
>
> Hive maven plugin versions are configured in $HIVE_HOME/pom.xml uniformly, while there
are still some plugin dependencies in module pom.xml does not use configured version.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message