hive-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Szehon Ho (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HIVE-8903) downgrade guava version for spark branch from 14.0.1 to 11.0.2.[Spark Branch]
Date Tue, 18 Nov 2014 06:53:33 GMT

    [ https://issues.apache.org/jira/browse/HIVE-8903?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14215791#comment-14215791
] 

Szehon Ho commented on HIVE-8903:
---------------------------------

Sorry I don't have the context, Marcelo had mentioned in HIVE-8854 that we need guava 14 for
something, is that resolved?

> downgrade guava version for spark branch from 14.0.1 to 11.0.2.[Spark Branch]
> -----------------------------------------------------------------------------
>
>                 Key: HIVE-8903
>                 URL: https://issues.apache.org/jira/browse/HIVE-8903
>             Project: Hive
>          Issue Type: Sub-task
>          Components: Spark
>            Reporter: Chengxiang Li
>            Assignee: Chengxiang Li
>              Labels: Spark-M3
>         Attachments: HIVE-8903.1-spark.patch
>
>
> Hive trunk depends on guava 11.0.2, same as Hadoop and Tez. Spark depends on guava 14.0.1,
which we shaded guava in its assembly jar to avoid conflict for Hive on Spark(HIVE-7387).
Guava version is upgrade to 14.0.2 in Hive spark branch, which should be unnecessary and lead
to guava  conflicts(HIVE-8854). We should downgrade guava dependency from 14.0.1 to 11.0.2
to keep consist with Hive trunk.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message