hive-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hive QA (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HIVE-8764) Windows: HiveServer2 TCP SSL cannot recognize localhost
Date Sat, 08 Nov 2014 01:55:34 GMT

    [ https://issues.apache.org/jira/browse/HIVE-8764?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14203128#comment-14203128
] 

Hive QA commented on HIVE-8764:
-------------------------------



{color:red}Overall{color}: -1 at least one tests failed

Here are the results of testing the latest attachment:
https://issues.apache.org/jira/secure/attachment/12680295/HIVE-8764.1.patch

{color:red}ERROR:{color} -1 due to 3 failed/errored test(s), 6672 tests executed
*Failed tests:*
{noformat}
org.apache.hadoop.hive.cli.TestCliDriver.testCliDriver_acid_join
org.apache.hadoop.hive.cli.TestCliDriver.testCliDriver_insert_nonacid_from_acid
org.apache.hive.hcatalog.streaming.TestStreaming.testTransactionBatchEmptyCommit
{noformat}

Test results: http://ec2-174-129-184-35.compute-1.amazonaws.com/jenkins/job/PreCommit-HIVE-TRUNK-Build/1694/testReport
Console output: http://ec2-174-129-184-35.compute-1.amazonaws.com/jenkins/job/PreCommit-HIVE-TRUNK-Build/1694/console
Test logs: http://ec2-174-129-184-35.compute-1.amazonaws.com/logs/PreCommit-HIVE-TRUNK-Build-1694/

Messages:
{noformat}
Executing org.apache.hive.ptest.execution.PrepPhase
Executing org.apache.hive.ptest.execution.ExecutionPhase
Executing org.apache.hive.ptest.execution.ReportingPhase
Tests exited with: TestsFailedException: 3 tests failed
{noformat}

This message is automatically generated.

ATTACHMENT ID: 12680295 - PreCommit-HIVE-TRUNK-Build

> Windows: HiveServer2 TCP SSL cannot recognize localhost 
> --------------------------------------------------------
>
>                 Key: HIVE-8764
>                 URL: https://issues.apache.org/jira/browse/HIVE-8764
>             Project: Hive
>          Issue Type: Bug
>          Components: HiveServer2
>    Affects Versions: 0.14.0
>            Reporter: Vaibhav Gumashta
>            Assignee: Vaibhav Gumashta
>             Fix For: 0.14.0
>
>         Attachments: HIVE-8764.1.patch
>
>
> Seen on windows and HS2 running in binary mode (http mode works fine; so does using dynamic
service discovery). Previously jdbc clients could use localhost:port to connect to the server,
now they explicitly need to specify hostname:port. With ZooKeeper indirection however, this
is not an issue coz uris on ZK are added in the hostname:port format anyway.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message