hive-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hive QA (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HIVE-8400) Fix building and packaging hwi war file
Date Wed, 22 Oct 2014 08:08:34 GMT

    [ https://issues.apache.org/jira/browse/HIVE-8400?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14179708#comment-14179708
] 

Hive QA commented on HIVE-8400:
-------------------------------



{color:red}Overall{color}: -1 at least one tests failed

Here are the results of testing the latest attachment:
https://issues.apache.org/jira/secure/attachment/12676226/HIVE-8400.1.patch

{color:red}ERROR:{color} -1 due to 2 failed/errored test(s), 6574 tests executed
*Failed tests:*
{noformat}
org.apache.hadoop.hive.cli.TestMinimrCliDriver.testCliDriver_schemeAuthority
org.apache.hive.minikdc.TestJdbcWithMiniKdc.testNegativeTokenAuth
{noformat}

Test results: http://ec2-174-129-184-35.compute-1.amazonaws.com/jenkins/job/PreCommit-HIVE-TRUNK-Build/1387/testReport
Console output: http://ec2-174-129-184-35.compute-1.amazonaws.com/jenkins/job/PreCommit-HIVE-TRUNK-Build/1387/console
Test logs: http://ec2-174-129-184-35.compute-1.amazonaws.com/logs/PreCommit-HIVE-TRUNK-Build-1387/

Messages:
{noformat}
Executing org.apache.hive.ptest.execution.PrepPhase
Executing org.apache.hive.ptest.execution.ExecutionPhase
Executing org.apache.hive.ptest.execution.ReportingPhase
Tests exited with: TestsFailedException: 2 tests failed
{noformat}

This message is automatically generated.

ATTACHMENT ID: 12676226 - PreCommit-HIVE-TRUNK-Build

> Fix building and packaging hwi war file
> ---------------------------------------
>
>                 Key: HIVE-8400
>                 URL: https://issues.apache.org/jira/browse/HIVE-8400
>             Project: Hive
>          Issue Type: Bug
>          Components: Web UI
>    Affects Versions: 0.13.1
>            Reporter: Pankit Thapar
>             Fix For: 0.14.0
>
>         Attachments: HIVE-8400.1.patch
>
>
> hive 0.11 used to have hwi-0.11.war file but it seems that hive 13 is not configured
to build a war file, instead it builds a jar file for hwi.
> A fix for this would be to change jar to war in hwi/pom.xml.
> Diff is below : 
> diff --git a/hwi/pom.xml b/hwi/pom.xml
> index 35c124b..88d83fb 100644
> --- a/hwi/pom.xml
> +++ b/hwi/pom.xml
> @@ -24,7 +24,7 @@
>    </parent>
>  
>    <artifactId>hive-hwi</artifactId>
> -  <packaging>jar</packaging>
> +  <packaging>war</packaging>
>    <name>Hive HWI</name>
> Please let me know if jar was intended or is it actually a bug so that I can submit a
patch for the fix.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message