hive-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Peter Slawski (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (HIVE-8400) Fix building and packaging hwi war file
Date Wed, 22 Oct 2014 00:26:35 GMT

     [ https://issues.apache.org/jira/browse/HIVE-8400?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Peter Slawski updated HIVE-8400:
--------------------------------
    Status: Patch Available  (was: Open)

This patch fixes this issue by modifying the pom.xml files for hwi and packaging modules.
The hwi jar file is still built and packaged but instead under the 'classes' maven classifier.

> Fix building and packaging hwi war file
> ---------------------------------------
>
>                 Key: HIVE-8400
>                 URL: https://issues.apache.org/jira/browse/HIVE-8400
>             Project: Hive
>          Issue Type: Bug
>          Components: Web UI
>    Affects Versions: 0.13.1
>            Reporter: Pankit Thapar
>             Fix For: 0.14.0
>
>         Attachments: HIVE-8400.1.patch
>
>
> hive 0.11 used to have hwi-0.11.war file but it seems that hive 13 is not configured
to build a war file, instead it builds a jar file for hwi.
> A fix for this would be to change jar to war in hwi/pom.xml.
> Diff is below : 
> diff --git a/hwi/pom.xml b/hwi/pom.xml
> index 35c124b..88d83fb 100644
> --- a/hwi/pom.xml
> +++ b/hwi/pom.xml
> @@ -24,7 +24,7 @@
>    </parent>
>  
>    <artifactId>hive-hwi</artifactId>
> -  <packaging>jar</packaging>
> +  <packaging>war</packaging>
>    <name>Hive HWI</name>
> Please let me know if jar was intended or is it actually a bug so that I can submit a
patch for the fix.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message