hive-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Pankit Thapar (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HIVE-8400) hwi does not have war file
Date Mon, 13 Oct 2014 23:22:35 GMT

    [ https://issues.apache.org/jira/browse/HIVE-8400?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14170211#comment-14170211
] 

Pankit Thapar commented on HIVE-8400:
-------------------------------------

I think this should go into 0.13.2 since this is something that is broken. Correct me if I
am wrong.

> hwi does not have war file
> --------------------------
>
>                 Key: HIVE-8400
>                 URL: https://issues.apache.org/jira/browse/HIVE-8400
>             Project: Hive
>          Issue Type: Bug
>          Components: Web UI
>    Affects Versions: 0.13.1
>            Reporter: Pankit Thapar
>             Fix For: 0.14.0
>
>
> hive 0.11 used to have hwi-0.11.war file but it seems that hive 13 is not configured
to build a war file, instead it builds a jar file for hwi.
> A fix for this would be to change jar to war in hwi/pom.xml.
> Diff is below : 
> diff --git a/hwi/pom.xml b/hwi/pom.xml
> index 35c124b..88d83fb 100644
> --- a/hwi/pom.xml
> +++ b/hwi/pom.xml
> @@ -24,7 +24,7 @@
>    </parent>
>  
>    <artifactId>hive-hwi</artifactId>
> -  <packaging>jar</packaging>
> +  <packaging>war</packaging>
>    <name>Hive HWI</name>
> Please let me know if jar was intended or is it actually a bug so that I can submit a
patch for the fix.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message