hive-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Xuefu Zhang (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HIVE-6165) Unify HivePreparedStatement from jdbc:hive and jdbc:hive2
Date Sat, 25 Oct 2014 15:27:33 GMT

    [ https://issues.apache.org/jira/browse/HIVE-6165?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14184129#comment-14184129
] 

Xuefu Zhang commented on HIVE-6165:
-----------------------------------

+1

> Unify HivePreparedStatement from jdbc:hive and jdbc:hive2
> ---------------------------------------------------------
>
>                 Key: HIVE-6165
>                 URL: https://issues.apache.org/jira/browse/HIVE-6165
>             Project: Hive
>          Issue Type: Bug
>          Components: HiveServer2, JDBC
>            Reporter: Helmut Zechmann
>            Priority: Minor
>         Attachments: HIVE-6165.1.patch.txt, HIVE-6165.1.patch.txt, HIVE-6165.2.patch,
HIVE-6165.2.patch.txt, HIVE-6165.2.patch.txt
>
>
> org.apache.hadoop.hive.jdbc.HivePreparedStatement.class from the hive jdbc driver and
org.apache.hive.jdbc.HivePreparedStatement.class from the hive2 jdbc drivers contain lots
of duplicate code. 
> Especially hive-HivePreparedStatement supports "setObject", while the hive2 version does
not.
> Share more code between the two to avoid duplicate work and to make sure that both support
the broadest possible feature set.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message