hive-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Thejas Nair <the...@hortonworks.com>
Subject [VOTE] officially stop supporting hadoop 0.20.x in hive 0.14 ?
Date Tue, 07 Oct 2014 22:53:48 GMT
I think it is time to revisit the support for hive support for hadoop
0.20. Trying to maintain support for it puts additional burden on hive
contributors.

The last hadoop 0.20.x version was released on Feb 2010. Hadoop 1.0
was released in Dec 2011.
I believe most users have moved on to hadoop 2.x or at least hadoop
1.x . The users if any that are still on hadoop 0.20 probably don't
tend to upgrade their hive versions as well.

With the move to maven for builds in hive 0.13, we don't have the
ability to compile against hadoop 0.20. (Nobody has complains about
that AFAIK). I am not sure if hive 0.13 works well against hadoop
0.20, as it is not clear if that combination is in use. Also, most
commercial vendors seem to be focussing on testing it against hadoop
2.x.

I think it is time to do away with this added burden of attempting to
support hadoop 0.20.x versions.

Here is my +1 for officially stopping support for hadoop 0.20.x in hive 0.14 .

Thanks,
Thejas

-- 
CONFIDENTIALITY NOTICE
NOTICE: This message is intended for the use of the individual or entity to 
which it is addressed and may contain information that is confidential, 
privileged and exempt from disclosure under applicable law. If the reader 
of this message is not the intended recipient, you are hereby notified that 
any printing, copying, dissemination, distribution, disclosure or 
forwarding of this communication is strictly prohibited. If you have 
received this communication in error, please contact the sender immediately 
and delete it from your system. Thank You.

Mime
View raw message