hive-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Josh Elser (JIRA)" <j...@apache.org>
Subject [jira] [Created] (HIVE-8257) Accumulo introduces old hadoop-client dependency
Date Thu, 25 Sep 2014 20:30:34 GMT
Josh Elser created HIVE-8257:
--------------------------------

             Summary: Accumulo introduces old hadoop-client dependency
                 Key: HIVE-8257
                 URL: https://issues.apache.org/jira/browse/HIVE-8257
             Project: Hive
          Issue Type: Bug
          Components: Build Infrastructure
            Reporter: Josh Elser
            Assignee: Josh Elser
            Priority: Critical
             Fix For: 0.14.0


It was brought to my attention that Accumulo is transitively bringing in some artifacts with
the wrong version of Hadoop.

Accumulo-1.6.0 sets the Hadoop version at 2.2.0 and uses hadoop-client to get its necessary
dependencies. Because there is no dependency with the correct version in Hive, this introduces
hadoop-2.2.0 dependencies.

A solution is to make sure that hadoop-client is set with the correct {{hadoop-20S.version}}
or {{hadoop-23.version}}.

Snippet from {{mvn dependency:tree -Phadoop-2}}
{noformat}
[INFO] --- maven-dependency-plugin:2.8:tree (default-cli) @ hive-accumulo-handler ---
[INFO] org.apache.hive:hive-accumulo-handler:jar:0.14.0-SNAPSHOT
[INFO] +- commons-lang:commons-lang:jar:2.6:compile
[INFO] +- commons-logging:commons-logging:jar:1.1.3:compile
[INFO] +- org.apache.accumulo:accumulo-core:jar:1.6.0:compile
...
[INFO] |  +- org.apache.hadoop:hadoop-client:jar:2.2.0:compile
[INFO] |  |  +- org.apache.hadoop:hadoop-hdfs:jar:2.4.0:compile
...
{noformat}



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message