hive-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hive QA (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HIVE-7972) hiveserver2 specific configuration file is not getting used
Date Thu, 04 Sep 2014 05:10:51 GMT

    [ https://issues.apache.org/jira/browse/HIVE-7972?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14120962#comment-14120962
] 

Hive QA commented on HIVE-7972:
-------------------------------



{color:red}Overall{color}: -1 at least one tests failed

Here are the results of testing the latest attachment:
https://issues.apache.org/jira/secure/attachment/12666378/HIVE-7972.1.patch

{color:red}ERROR:{color} -1 due to 3 failed/errored test(s), 6142 tests executed
*Failed tests:*
{noformat}
org.apache.hadoop.hive.cli.TestMinimrCliDriver.testCliDriver_schemeAuthority
org.apache.hive.hcatalog.pig.TestHCatLoader.testReadDataPrimitiveTypes
org.apache.hive.service.TestHS2ImpersonationWithRemoteMS.testImpersonation
{noformat}

Test results: http://ec2-174-129-184-35.compute-1.amazonaws.com/jenkins/job/PreCommit-HIVE-TRUNK-Build/629/testReport
Console output: http://ec2-174-129-184-35.compute-1.amazonaws.com/jenkins/job/PreCommit-HIVE-TRUNK-Build/629/console
Test logs: http://ec2-174-129-184-35.compute-1.amazonaws.com/logs/PreCommit-HIVE-TRUNK-Build-629/

Messages:
{noformat}
Executing org.apache.hive.ptest.execution.PrepPhase
Executing org.apache.hive.ptest.execution.ExecutionPhase
Executing org.apache.hive.ptest.execution.ReportingPhase
Tests exited with: TestsFailedException: 3 tests failed
{noformat}

This message is automatically generated.

ATTACHMENT ID: 12666378

> hiveserver2 specific configuration file is not getting used
> -----------------------------------------------------------
>
>                 Key: HIVE-7972
>                 URL: https://issues.apache.org/jira/browse/HIVE-7972
>             Project: Hive
>          Issue Type: Bug
>            Reporter: Thejas M Nair
>            Assignee: Thejas M Nair
>         Attachments: HIVE-7972.1.patch
>
>
> The HiveServer2 specific configuration file introduced in HIVE-7342 is not getting used
when hiveserver2 is started from commandline. This is because the HiveConf used in HiveServer2.init
is actually created before HiveServer2 constructor is called.
> The tests are using embedded HiveServer2 which does not go through HiveServer2.main and
don't show this issue.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message