hive-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Owen O'Malley (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HIVE-7571) RecordUpdater should read virtual columns from row
Date Wed, 03 Sep 2014 14:59:51 GMT

    [ https://issues.apache.org/jira/browse/HIVE-7571?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14119923#comment-14119923
] 

Owen O'Malley commented on HIVE-7571:
-------------------------------------

+1 LGTM

You might want to replace s/recIdCol/RecordIdColumn/g to be more readable, since it is a public
API.

> RecordUpdater should read virtual columns from row
> --------------------------------------------------
>
>                 Key: HIVE-7571
>                 URL: https://issues.apache.org/jira/browse/HIVE-7571
>             Project: Hive
>          Issue Type: Sub-task
>          Components: Transactions
>    Affects Versions: 0.13.0
>            Reporter: Alan Gates
>            Assignee: Alan Gates
>         Attachments: HIVE-7571.2.patch, HIVE-7571.WIP.patch, HIVE-7571.patch
>
>
> Currently RecordUpdater.update and delete take rowid and original transaction as parameters.
 These values are already present in the row as part of the new ROW__ID virtual column in
HIVE-7513, and thus can be read by the writer from there.  And the writer will already have
to handle skipping ROW__ID when writing, so it needs to be aware of that column anyone.
> We could instead read the values from ROW__ID and then remove it from the object inspector
in FileSinkOperator, but this will be hard in the vectorization case where rows are being
dealt with 10k at a time.
> For these reasons it makes more sense to do this work in the writer.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message