hive-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Chengxiang Li (JIRA)" <j...@apache.org>
Subject [jira] [Created] (HIVE-7387) Guava version conflict between hadoop and spark
Date Fri, 11 Jul 2014 03:15:05 GMT
Chengxiang Li created HIVE-7387:
-----------------------------------

             Summary: Guava version conflict between hadoop and spark
                 Key: HIVE-7387
                 URL: https://issues.apache.org/jira/browse/HIVE-7387
             Project: Hive
          Issue Type: Bug
          Components: Spark
            Reporter: Chengxiang Li


hadoop-hdfs and hadoop-comman have dependency on guava-11.0.2.jar, and spark dependent on
guava-14.0.1.jar. guava-11.0.2 has API conflict with guava-14.0.1, as Hive CLI load both dependency
into classpath currently, query failed on either spark engine or mr engine.



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message