hive-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Szehon Ho (JIRA)" <>
Subject [jira] [Created] (HIVE-7220) Empty dir in external table causes issue (root_dir_external_table.q failure)
Date Wed, 11 Jun 2014 23:05:02 GMT
Szehon Ho created HIVE-7220:

             Summary: Empty dir in external table causes issue (root_dir_external_table.q
                 Key: HIVE-7220
             Project: Hive
          Issue Type: Bug
            Reporter: Szehon Ho

While looking at root_dir_external_table.q failure, which is doing a query on an external
table located at root ('/'), I noticed that latest Hadoop2 CombineFileInputFormat returns
split representing empty directories (like '/Users'), which leads to failure in Hive's CombineFileRecordReader
as it tries to open the directory for processing.

Tried with an external table in a normal HDFS directory, and it also returns the same error.
 Looks like a real bug.

This message was sent by Atlassian JIRA

View raw message