hive-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Swarnim Kulkarni (JIRA)" <>
Subject [jira] [Commented] (HIVE-7048) CompositeKeyHBaseFactory should not use FamilyFilter
Date Wed, 21 May 2014 15:10:38 GMT


Swarnim Kulkarni commented on HIVE-7048:

User desiring of this capability would have to provided their own key factory class.

My only concern with that approach is that for a non-hive developer, it is probably too much
work to write custom implementations with pushdown logic without much guidance. Also I cannot
imagine a case where someone wouldn't require the capability to set range scans or filters
and do full-table scans instead. So it might just cause unnecessary duplication of the same
logic across implementations which could otherwise be easily abstracted out in hive itself.
Creating hbase filters is a much more universally known concept. Hence my proposal for asking
them to implement only that as it would ease things out for them. Also since the CompositeKeyHBaseFactory
got merged just a few days back, I don't think we need to worry too much about passivity at
this point by making the class abstract.

Anyways, just my 0.02 :). I am fine with letting consumers define the complete logic. Just
in my opinion(and experience), it's not very easy. 

> CompositeKeyHBaseFactory should not use FamilyFilter
> ----------------------------------------------------
>                 Key: HIVE-7048
>                 URL:
>             Project: Hive
>          Issue Type: Improvement
>          Components: HBase Handler
>            Reporter: Swarnim Kulkarni
>            Assignee: Swarnim Kulkarni
>            Priority: Blocker
>         Attachments: HIVE-7048.1.patch.txt
> HIVE-6411 introduced a more generic way to provide composite key implementations via
custom factory implementations. However it seems like the CompositeHBaseKeyFactory implementation
uses a FamilyFilter for row key scans which doesn't seem appropriate. This should be investigated
further and if possible replaced with a RowRangeScanFilter.

This message was sent by Atlassian JIRA

View raw message