hive-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Xuefu Zhang" <xzh...@cloudera.com>
Subject Re: Review Request 21831: Make the behavior of CompositeKeyHBaseFactory consistent
Date Fri, 23 May 2014 00:41:39 GMT

-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/21831/#review43800
-----------------------------------------------------------



hbase-handler/src/java/org/apache/hadoop/hive/hbase/HBaseKeyDecomposedPredicate.java
<https://reviews.apache.org/r/21831/#comment78082>

    License header



hbase-handler/src/java/org/apache/hadoop/hive/hbase/HBaseKeyDecomposedPredicate.java
<https://reviews.apache.org/r/21831/#comment78083>

    This class name seems needing to be improved. Howe about AbstractHBaseKeyPredicateDecomposer?



hbase-handler/src/java/org/apache/hadoop/hive/hbase/HBaseKeyDecomposedPredicate.java
<https://reviews.apache.org/r/21831/#comment78086>

    How about naming it decomposePredicate()



hbase-handler/src/java/org/apache/hadoop/hive/hbase/HBaseKeyDecomposedPredicate.java
<https://reviews.apache.org/r/21831/#comment78084>

    This should probably be protected.



hbase-handler/src/java/org/apache/hadoop/hive/hbase/HBaseKeyDecomposedPredicate.java
<https://reviews.apache.org/r/21831/#comment78085>

    Same as above.



hbase-handler/src/java/org/apache/hadoop/hive/hbase/HBaseSerDeParameters.java
<https://reviews.apache.org/r/21831/#comment78081>

    I don't see any use of this.


- Xuefu Zhang


On May 22, 2014, 10:43 p.m., Swarnim Kulkarni wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/21831/
> -----------------------------------------------------------
> 
> (Updated May 22, 2014, 10:43 p.m.)
> 
> 
> Review request for hive.
> 
> 
> Bugs: HIVE-7048
>     https://issues.apache.org/jira/browse/HIVE-7048
> 
> 
> Repository: hive-git
> 
> 
> Description
> -------
> 
> HIVE-6411 introduced a more generic way to provide composite key implementations via
custom factory implementations. However it seems like the CompositeHBaseKeyFactory implementation
uses a FamilyFilter for row key scans which doesn't seem appropriate. This should be investigated
further and if possible replaced with a RowRangeScanFilter.
> 
> 
> Diffs
> -----
> 
>   hbase-handler/src/java/org/apache/hadoop/hive/hbase/CompositeHBaseKeyFactory.java 53fa995

>   hbase-handler/src/java/org/apache/hadoop/hive/hbase/HBaseKeyDecomposedPredicate.java
PRE-CREATION 
>   hbase-handler/src/java/org/apache/hadoop/hive/hbase/HBaseSerDeParameters.java 07db3af

>   hbase-handler/src/test/org/apache/hadoop/hive/hbase/TestHBaseKeyFactory3.java PRE-CREATION

>   hbase-handler/src/test/queries/positive/hbase_custom_key3.q PRE-CREATION 
>   hbase-handler/src/test/results/positive/hbase_custom_key3.q.out PRE-CREATION 
> 
> Diff: https://reviews.apache.org/r/21831/diff/
> 
> 
> Testing
> -------
> 
> Tests included with the patch.
> 
> 
> Thanks,
> 
> Swarnim Kulkarni
> 
>


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message