hive-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Thejas Nair <the...@hortonworks.com>
Subject Re: What is the minimal required version of Hadoop for Hive 0.13.0?
Date Wed, 23 Apr 2014 20:01:18 GMT
There is a jira for the hadoop 1.0.x compatibility issue.
https://issues.apache.org/jira/browse/HIVE-6962
I have suggested a possible workaround there. There is no patch for it yet.

I am planning to propose a 0.13.1 release, primarily for the issues
around use of Oracle as metastore database, and one in SQL standard
authorization (HIVE-6945, HIVE-6919).
We can also include patch to get hive working with older versions of
hadoop, specially 1.x versions.

Hive build and tests are currently run against hadoop 1.2.1 and 2.3.0
versions (as you can see in pom.xml). But I don't believe there was a
conscious decision to have 1.2.1 as the *minimum* required version.


On Wed, Apr 23, 2014 at 7:20 AM, David Gayou <david.gayou@kxen.com> wrote:
> I actually have pretty the same issue with Hadoop 1.1.2
>
> There is a jira issue opened here :
> https://issues.apache.org/jira/browse/HIVE-6962
> with a link to the issue that created our problem.
>
> A quick search in release notes seem's to indicate that the unset method
> appeared in the Haddop 1.2.1
>
> Is it now the minimal required version ?
> If not, will there be a Hive 0.13.1 for older hadoop?
>
> Regards,
>
> David
>
>
> On Wed, Apr 23, 2014 at 4:00 PM, Dmitry Vasilenko <dvasilen@gmail.com>
> wrote:
>>
>>
>> Hive 0.12.0 (and previous versions) worked with Hadoop 0.20.x, 0.23.x.y,
>> 1.x.y, 2.x.y.
>>
>> Hive 0.13.0 did not work with Hadoop 0.20.x out of the box and to make it
>> work I had to patch Hadoop installation and add Path(URL) constructor and
>> Configuration.unset() method.
>>
>> After that the basic functionality seems to be working.
>>
>> Both issues originate from the org.apache.hadoop.hive.ql.exec.Utilities
>>
>> I know that Hadoop 0.20.x is old but some of us still have to work with
>> that version. So does anyone know what is the minimal required version of
>> Hadoop for Hive 0.13.0?
>>
>> Thanks
>> Dmitry Vasilenko
>>
>

-- 
CONFIDENTIALITY NOTICE
NOTICE: This message is intended for the use of the individual or entity to 
which it is addressed and may contain information that is confidential, 
privileged and exempt from disclosure under applicable law. If the reader 
of this message is not the intended recipient, you are hereby notified that 
any printing, copying, dissemination, distribution, disclosure or 
forwarding of this communication is strictly prohibited. If you have 
received this communication in error, please contact the sender immediately 
and delete it from your system. Thank You.

Mime
View raw message