hive-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Remus Rusanu (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HIVE-6553) hive CLI shell use of `dirname "$0"` prevents it from being linked from other directories
Date Fri, 07 Mar 2014 11:13:44 GMT

    [ https://issues.apache.org/jira/browse/HIVE-6553?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13923787#comment-13923787
] 

Remus Rusanu commented on HIVE-6553:
------------------------------------

I'm not comfortable submitting a patch that uses readlink because readlink is not available
on all platforms and I think readlink -f is not available on OS X. Given that no one complained
about this issue before, destabilizing the main CLI seems too risky.

> hive CLI shell use of `dirname "$0"` prevents it from being linked from other directories
> -----------------------------------------------------------------------------------------
>
>                 Key: HIVE-6553
>                 URL: https://issues.apache.org/jira/browse/HIVE-6553
>             Project: Hive
>          Issue Type: Bug
>            Reporter: Remus Rusanu
>            Priority: Minor
>
> I tried making /usr/bin/hive a link to /usr/lib/hive-0.14/bin/hive . But the launch fails
because:
> {code}
> bin=`dirname "$0"`
> bin=`cd "$bin"; pwd`
> . "$bin"/hive-config.sh
> {code}
> So I used a readlink -f first, to locate the proper script home, and then it works fine.




--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message