hive-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Fei Teng <>
Subject issue with datanucleus when building hive
Date Mon, 24 Feb 2014 04:46:41 GMT
Hello hive developer,

I am a programmer who tried to deploy Hive in my company. But I ran into an issue when I tried
to build latest hive 0.13 from

The problem is when executing mvn clean install, I got the following error for no good reason:

[ERROR] Failed to execute goal org.datanucleus:datanucleus-maven-plugin:3.3.0-release:enhance
(default) on project hive-metastore: Error executing DataNucleus tool org.datanucleus.enhancer.DataNucleusEnhancer:
InvocationTargetException: Plugin (Bundle) "org.datanucleus" is already registered. Ensure
you dont have multiple JAR versions of the same plugin in the classpath. The URL "file:/nfs/rinfs1/home/homedirs/feiteng/.m2/repository/org/datanucleus/datanucleus-core/3.2.2/datanucleus-core-3.2.2.jar"
is already registered, and you are trying to register an identical plugin located at URL "file:/u/feiteng/.m2/repository/org/datanucleus/datanucleus-core/3.2.2/datanucleus-core-3.2.2.jar."
-> [Help 1]

I am wondering if I did something wrong or it is a bug in hive 0.13 release?

Thank you in advance for all kinds of help you can give me!
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message