hive-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Lefty Leverenz (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HIVE-5652) Improve JavaDoc of UDF class
Date Sat, 21 Dec 2013 11:36:09 GMT

    [ https://issues.apache.org/jira/browse/HIVE-5652?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13854843#comment-13854843
] 

Lefty Leverenz commented on HIVE-5652:
--------------------------------------

Good improvements.  Just two trivial suggestions:

(1) Add a period before the closing parenthesis in the second sentence here: 
{code}
+ * <li>{@code public String evaluate(List<Integer> a);} (Note that Hive Arrays
are represented as
+ * {@link java.util.List Lists} in Hive. So an {@code
+ * ARRAY<int>} column would be passed in as a {@code List<Integer>})</li>
{code}

(2) Omit "the" here (line 8 of the patch, unchanged text):
{code}
 /**
  * A User-defined function (UDF) for the use with Hive.
{code}

> Improve JavaDoc of UDF class
> ----------------------------
>
>                 Key: HIVE-5652
>                 URL: https://issues.apache.org/jira/browse/HIVE-5652
>             Project: Hive
>          Issue Type: Improvement
>          Components: Documentation
>            Reporter: Lars Francke
>            Assignee: Lars Francke
>            Priority: Trivial
>         Attachments: HIVE-5652.1.patch
>
>
> I think the JavaDoc for the UDF class can be improved. I'll attach a patch shortly.



--
This message was sent by Atlassian JIRA
(v6.1.4#6159)

Mime
View raw message