hive-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Brock Noland (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (HIVE-5828) Make shims dependecny on specific hadoop hive shims optional
Date Fri, 15 Nov 2013 15:57:20 GMT

     [ https://issues.apache.org/jira/browse/HIVE-5828?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Brock Noland resolved HIVE-5828.
--------------------------------

    Resolution: Duplicate

Since the change is already included in HIVE-5741 I will mark this one resolved.  Sorry for
the trouble Vikram!

> Make shims dependecny on specific hadoop hive shims optional
> ------------------------------------------------------------
>
>                 Key: HIVE-5828
>                 URL: https://issues.apache.org/jira/browse/HIVE-5828
>             Project: Hive
>          Issue Type: Bug
>          Components: Build Infrastructure
>    Affects Versions: 0.13.0
>            Reporter: Vikram Dixit K
>            Assignee: Vikram Dixit K
>
> The issue now is that hive-shims depends on hive-shims-0.20, hive-shims-0.20S, and hive-shims-0.23.
ql depends on hive-shims. When ql brings in hive-shims it brings it all transitive dependencies
which include three different versions of hadoop.  Since hive-shims should not bring any dependencies
with it because we expect the end-user module to bring it's hadoop hadoop version.
> One way to do that is to mark all the hive-shims-* dependencies in hive-shims optional.



--
This message was sent by Atlassian JIRA
(v6.1#6144)

Mime
View raw message