hive-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "omicron (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (HIVE-5746) "hive.files.umask.value" is not work
Date Wed, 06 Nov 2013 07:04:19 GMT

     [ https://issues.apache.org/jira/browse/HIVE-5746?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

omicron resolved HIVE-5746.
---------------------------

      Resolution: Fixed
    Release Note: 
it resolved by writing:
        <property>
                <name>fs.permissions.umask-mode</name>
                <value>077</value>
        </property>
in hive-site.xml

> "hive.files.umask.value" is not work
> ------------------------------------
>
>                 Key: HIVE-5746
>                 URL: https://issues.apache.org/jira/browse/HIVE-5746
>             Project: Hive
>          Issue Type: Test
>          Components: Authentication, Authorization
>    Affects Versions: 0.12.0
>         Environment: hive 0.12.0´╝îhadoop 2.0.3
>            Reporter: omicron
>            Priority: Trivial
>
> my "hive-site.xml" contents:
>          <property>
>                 <name>hive.warehouse.subdir.inherit.perms</name>
>                 <value>false</value>
>         </property>
>         <property>
>                 <name>hive.files.umask.value</name>
>                 <value>0077</value>
>         </property>
> but the folder that hive create has permisson 755. 
> PS: hadoop "core-site.xml" has :
>         <property>
>                 <name>fs.permissions.umask-mode</name>
>                 <value>077</value>
>         </property>
> and when i create folder using "hdfs dfs -mkdir XXX",the permission of folder is right
(700).
> so is it a bug ? or i missed something



--
This message was sent by Atlassian JIRA
(v6.1#6144)

Mime
View raw message