hive-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Eugene Koifman <ekoif...@hortonworks.com>
Subject hcat tests with MVN
Date Fri, 22 Nov 2013 18:12:04 GMT
Hi,
I've noticed a couple of problems.


1) running "mvn tests" from hcatalog/ runs the tests under core and
hcatalog-pig-adapter submodules but not any of the other modules
(webhcat/java-client, webhcat/svr, etc).  Though if I cd to the appropriate
submodule ant run "mvn test" the tests are run.

2) "mvn surefire-report:report" from hcatalog generates .html files with
test results in the ./target/site/surefire-report.html of each submodule,
but not a single .html that includes results for all tests.
 (hcatalog/target/site/surefire-report.html is generated but contains 0
tests)

Does anyone have suggestions on how to fix these?

Thanks,
Eugene

-- 
CONFIDENTIALITY NOTICE
NOTICE: This message is intended for the use of the individual or entity to 
which it is addressed and may contain information that is confidential, 
privileged and exempt from disclosure under applicable law. If the reader 
of this message is not the intended recipient, you are hereby notified that 
any printing, copying, dissemination, distribution, disclosure or 
forwarding of this communication is strictly prohibited. If you have 
received this communication in error, please contact the sender immediately 
and delete it from your system. Thank You.

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message