hive-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Vaibhav Gumashta (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HIVE-5474) TestThriftHttpCLIService.testExecuteStatement fails in sequential run
Date Sun, 06 Oct 2013 23:36:42 GMT

    [ https://issues.apache.org/jira/browse/HIVE-5474?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13787826#comment-13787826
] 

Vaibhav Gumashta commented on HIVE-5474:
----------------------------------------

This looks like a test only issue. I tried connecting with beeline in http mode (note: http
currently works in auth: NOSASL and does not support doAs), and it works fine. 

In the tests, I'm setting lock manager to embedded, but looks like the test run in the previous
test case is not releasing the lock on the table. I tried running TestThriftBinaryCLIService
and TestThriftHttpCLIService sequentially using the patch in: [HIVE-4907|https://issues.apache.org/jira/browse/HIVE-4907].


However, in my opinion, this should not be a blocker for 0.12.

> TestThriftHttpCLIService.testExecuteStatement fails in sequential run
> ---------------------------------------------------------------------
>
>                 Key: HIVE-5474
>                 URL: https://issues.apache.org/jira/browse/HIVE-5474
>             Project: Hive
>          Issue Type: Bug
>          Components: HiveServer2
>            Reporter: Thejas M Nair
>            Assignee: Vaibhav Gumashta
>
> This is seen in hive 0.12 branch sequential test run. TestThriftHttpCLIService.testExecuteStatement
> https://builds.apache.org/job/Hive-branch-0.12-hadoop1/13/testReport/org.apache.hive.service.cli.thrift/TestThriftHttpCLIService/testExecuteStatement/
> stderr has "FAILED: Error in acquiring locks: Locks on the underlying
> objects cannot be acquired. retry after some time"



--
This message was sent by Atlassian JIRA
(v6.1#6144)

Mime
View raw message