hive-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Yin Huai (JIRA)" <>
Subject [jira] [Commented] (HIVE-5385) StringUtils is not in commons codec 1.3
Date Fri, 27 Sep 2013 18:46:06 GMT


Yin Huai commented on HIVE-5385:

When I compile hive with "ant clean package -Dhadoop.version=0.20.2", I
can see both "commons-codec-1.4.jar" and "commons-codec-1.6.jar" in "build/dist/lib". 

> StringUtils is not in commons codec 1.3
> ---------------------------------------
>                 Key: HIVE-5385
>                 URL:
>             Project: Hive
>          Issue Type: Bug
>            Reporter: Yin Huai
>            Priority: Trivial
> In ThriftHttpServlet introduced by HIVE-4763, StringUtils is imported which was introduced
by commons codec 1.4. But, our 0.20 shims depends on commons codec 1.3. Our eclipse classpath
template is also using libs of 0.20 shims. So, we will get two errors in eclipse. 
> Compiling hive will not have a problem because we are loading codec 1.4 for project service
(1.4 is also used when "-Dhadoop.version=0.20.2").

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see:

View raw message