hive-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Phabricator (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HIVE-5267) Use array instead of Collections if possible in DemuxOperator
Date Mon, 16 Sep 2013 20:44:51 GMT

    [ https://issues.apache.org/jira/browse/HIVE-5267?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13768732#comment-13768732
] 

Phabricator commented on HIVE-5267:
-----------------------------------

yhuai has commented on the revision "HIVE-5267 [jira] Use array instead of Collections if
possible in DemuxOperator".

  one minor issue. other than it, the diff looks good to me.

INLINE COMMENTS
  ql/src/java/org/apache/hadoop/hive/ql/exec/DemuxOperator.java:118 The size of childInputObjInspectors
is the number of children. Let's use "new ObjectInspector[childOperators.size()];"

REVISION DETAIL
  https://reviews.facebook.net/D12867

To: JIRA, navis
Cc: yhuai

                
> Use array instead of Collections if possible in DemuxOperator
> -------------------------------------------------------------
>
>                 Key: HIVE-5267
>                 URL: https://issues.apache.org/jira/browse/HIVE-5267
>             Project: Hive
>          Issue Type: Improvement
>          Components: Query Processor
>            Reporter: Navis
>            Assignee: Navis
>            Priority: Trivial
>         Attachments: HIVE-5267.D12867.1.patch
>
>
> DemuxOperator accesses Maps twice+ for each row, which can be replaced by array.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message