hive-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hudson (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HIVE-3764) Support metastore version consistency check
Date Sun, 22 Sep 2013 01:56:53 GMT

    [ https://issues.apache.org/jira/browse/HIVE-3764?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13773948#comment-13773948
] 

Hudson commented on HIVE-3764:
------------------------------

FAILURE: Integrated in Hive-trunk-hadoop2-ptest #110 (See [https://builds.apache.org/job/Hive-trunk-hadoop2-ptest/110/])
HIVE-3764 : Support metastore version consistency check (Prasad Mujumdar via Ashutosh Chauhan)
(hashutosh: http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1525288)
* /hive/trunk/build-common.xml
* /hive/trunk/common/src/java/org/apache/hadoop/hive/conf/HiveConf.java
* /hive/trunk/conf/hive-default.xml.template
* /hive/trunk/metastore/scripts/upgrade/derby/014-HIVE-3764.derby.sql
* /hive/trunk/metastore/scripts/upgrade/derby/hive-schema-0.12.0.derby.sql
* /hive/trunk/metastore/scripts/upgrade/derby/hive-schema-0.13.0.derby.sql
* /hive/trunk/metastore/scripts/upgrade/derby/upgrade-0.10.0-to-0.11.0.derby.sql
* /hive/trunk/metastore/scripts/upgrade/derby/upgrade-0.11.0-to-0.12.0.derby.sql
* /hive/trunk/metastore/scripts/upgrade/derby/upgrade-0.12.0-to-0.13.0.derby.sql
* /hive/trunk/metastore/scripts/upgrade/derby/upgrade.order.derby
* /hive/trunk/metastore/scripts/upgrade/mysql/014-HIVE-3764.mysql.sql
* /hive/trunk/metastore/scripts/upgrade/mysql/hive-schema-0.12.0.mysql.sql
* /hive/trunk/metastore/scripts/upgrade/mysql/hive-schema-0.13.0.mysql.sql
* /hive/trunk/metastore/scripts/upgrade/mysql/upgrade-0.11.0-to-0.12.0.mysql.sql
* /hive/trunk/metastore/scripts/upgrade/mysql/upgrade-0.12.0-to-0.13.0.mysql.sql
* /hive/trunk/metastore/scripts/upgrade/mysql/upgrade.order.mysql
* /hive/trunk/metastore/scripts/upgrade/oracle/014-HIVE-3764.oracle.sql
* /hive/trunk/metastore/scripts/upgrade/oracle/hive-schema-0.12.0.oracle.sql
* /hive/trunk/metastore/scripts/upgrade/oracle/hive-schema-0.13.0.oracle.sql
* /hive/trunk/metastore/scripts/upgrade/oracle/upgrade-0.10.0-to-0.11.0.mysql.sql
* /hive/trunk/metastore/scripts/upgrade/oracle/upgrade-0.11.0-to-0.12.0.oracle.sql
* /hive/trunk/metastore/scripts/upgrade/oracle/upgrade-0.12.0-to-0.13.0.oracle.sql
* /hive/trunk/metastore/scripts/upgrade/oracle/upgrade.order.oracle
* /hive/trunk/metastore/scripts/upgrade/postgres/014-HIVE-3764.postgres.sql
* /hive/trunk/metastore/scripts/upgrade/postgres/hive-schema-0.12.0.postgres.sql
* /hive/trunk/metastore/scripts/upgrade/postgres/hive-schema-0.13.0.postgres.sql
* /hive/trunk/metastore/scripts/upgrade/postgres/upgrade-0.11.0-to-0.12.0.postgres.sql
* /hive/trunk/metastore/scripts/upgrade/postgres/upgrade-0.12.0-to-0.13.0.postgres.sql
* /hive/trunk/metastore/scripts/upgrade/postgres/upgrade.order.postgres
* /hive/trunk/metastore/src/java/org/apache/hadoop/hive/metastore/HiveMetaStore.java
* /hive/trunk/metastore/src/java/org/apache/hadoop/hive/metastore/MetaStoreSchemaInfo.java
* /hive/trunk/metastore/src/java/org/apache/hadoop/hive/metastore/ObjectStore.java
* /hive/trunk/metastore/src/java/org/apache/hadoop/hive/metastore/RawStore.java
* /hive/trunk/metastore/src/model/org/apache/hadoop/hive/metastore/model/MVersionTable.java
* /hive/trunk/metastore/src/model/package.jdo
* /hive/trunk/metastore/src/test/org/apache/hadoop/hive/metastore/DummyRawStoreControlledCommit.java
* /hive/trunk/metastore/src/test/org/apache/hadoop/hive/metastore/DummyRawStoreForJdoConnection.java
* /hive/trunk/metastore/src/test/org/apache/hadoop/hive/metastore/TestMetastoreVersion.java

                
> Support metastore version consistency check
> -------------------------------------------
>
>                 Key: HIVE-3764
>                 URL: https://issues.apache.org/jira/browse/HIVE-3764
>             Project: Hive
>          Issue Type: Improvement
>          Components: Metastore
>    Affects Versions: 0.8.0, 0.9.0, 0.10.0, 0.11.0
>            Reporter: Prasad Mujumdar
>            Assignee: Prasad Mujumdar
>             Fix For: 0.13.0
>
>         Attachments: HIVE-3764-12.3.patch, HIVE-3764.1.patch, HIVE-3764.2.patch, HIVE-3764-trunk.3.patch
>
>
> Today there's no version/compatibility information stored in hive metastore. Also the
datanucleus configuration property to automatically create missing tables is enabled by default.
If you happen to start an older or newer hive or don't run the correct upgrade scripts during
migration, the metastore would end up corrupted. The autoCreate schema is not always sufficient
to upgrade metastore when migrating to newer release. It's not supported with all databases.
Besides the migration often involves altering existing table, changing or moving data etc.
> Hence it's very useful to have some consistency check to make sure that hive is using
correct metastore and for production systems the schema is not automatically by running hive.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message