hive-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Owen O'Malley (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HIVE-5112) Upgrade protobuf to 2.5 from 2.4
Date Tue, 20 Aug 2013 21:41:53 GMT

    [ https://issues.apache.org/jira/browse/HIVE-5112?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13745476#comment-13745476
] 

Owen O'Malley commented on HIVE-5112:
-------------------------------------

Obviously, part of what Maven helps with is finding where you are using inconsistent versions
of libraries. We need that.

You can't really create a shim for protobuf. My understanding is that you can use:
* 2.5 generated code only with the 2.5 library
* 2.4 generated code with either the 2.4 or 2.5 library

Maybe we should update the dependency to 2.5, but leave the generated code as it is.
                
> Upgrade protobuf to 2.5 from 2.4
> --------------------------------
>
>                 Key: HIVE-5112
>                 URL: https://issues.apache.org/jira/browse/HIVE-5112
>             Project: Hive
>          Issue Type: Improvement
>            Reporter: Brock Noland
>            Assignee: Owen O'Malley
>         Attachments: HIVE-5112.D12429.1.patch
>
>
> Hadoop and Hbase have both upgraded protobuf. We should as well.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message