hive-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Edward Capriolo (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HIVE-4843) Refactoring MapRedTask and ExecDriver for better re-usability (for tez) and readability
Date Tue, 30 Jul 2013 05:23:50 GMT

    [ https://issues.apache.org/jira/browse/HIVE-4843?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13723419#comment-13723419
] 

Edward Capriolo commented on HIVE-4843:
---------------------------------------

{code}
List<Path> inputPaths = Utilities.getInputPaths(newJob, selectTask.getWork().getMapWork(),
emptyScratchDir.toString(), ctx);
{code}

Can we remove any Path/File toString() and just pass the Path if possible?
                
> Refactoring MapRedTask and ExecDriver for better re-usability (for tez) and readability
> ---------------------------------------------------------------------------------------
>
>                 Key: HIVE-4843
>                 URL: https://issues.apache.org/jira/browse/HIVE-4843
>             Project: Hive
>          Issue Type: Bug
>    Affects Versions: 0.12.0, tez-branch
>            Reporter: Vikram Dixit K
>            Assignee: Vikram Dixit K
>         Attachments: HIVE-4843.1.patch, HIVE-4843.2.patch, HIVE-4843.3.patch, HIVE-4843.4.patch
>
>
> Currently, there are static apis in multiple locations in ExecDriver and MapRedTask that
can be leveraged if put in the already existing utility class in the exec package. This would
help making the code more maintainable, readable and also re-usable by other run-time infra
such as tez.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message