hive-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Brock Noland (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HIVE-4838) Refactor MapJoin HashMap code to improve testability and readability
Date Fri, 12 Jul 2013 18:07:49 GMT

    [ https://issues.apache.org/jira/browse/HIVE-4838?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13707181#comment-13707181
] 

Brock Noland commented on HIVE-4838:
------------------------------------

Hi,

Correct there is. It's related to the snippet of code I posted earlier. Basically the equals
implementation of MapJoinDoubleKey (and MapJoinObjectKey) is incorrect resulting in different
results for the following query depending on how it executed (map-side vs reduce-side):

{noformat}
SELECT /*+ MAPJOIN(a) */ * FROM smb_input1 a JOIN smb_input1 b ON a.key <=> b.key AND
a.value <=> b.value ORDER BY a.key, a.value, b.key, b.value;
{noformat}

Brock
                
> Refactor MapJoin HashMap code to improve testability and readability
> --------------------------------------------------------------------
>
>                 Key: HIVE-4838
>                 URL: https://issues.apache.org/jira/browse/HIVE-4838
>             Project: Hive
>          Issue Type: Bug
>            Reporter: Brock Noland
>            Assignee: Brock Noland
>         Attachments: HIVE-4838.patch, HIVE-4838.patch
>
>
> MapJoin is an essential component for high performance joins in Hive and the current
code has done great service for many years. However, the code is showing it's age and currently
suffers  from the following issues:
> * Uses static state via the MapJoinMetaData class to pass serialization metadata to the
Key, Row classes.
> * The api of a logical "Table Container" is not defined and therefore it's unclear what
apis HashMapWrapper 
> needs to publicize. Additionally HashMapWrapper has many used public methods.
> * HashMapWrapper contains logic to serialize, test memory bounds, and implement the table
container. Ideally these logical units could be seperated
> * HashTableSinkObjectCtx has unused fields and unused methods
> * CommonJoinOperator and children use ArrayList on left hand side when only List is required
> * There are unused classes MRU, DCLLItemm and classes which duplicate functionality MapJoinSingleKey
and MapJoinDoubleKeys

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message