hive-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ashutosh Chauhan (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HIVE-4406) Missing "/" or "/<dbname>" in hs2 jdbc uri switches mode to embedded mode
Date Mon, 01 Jul 2013 20:38:20 GMT

    [ https://issues.apache.org/jira/browse/HIVE-4406?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13697147#comment-13697147
] 

Ashutosh Chauhan commented on HIVE-4406:
----------------------------------------

Aah.. sorry [~thejas] Missed your comment. I already committed it. Will you like to create
a followup jira for this?
                
> Missing "/" or "/<dbname>" in hs2 jdbc uri switches mode to embedded mode
> -------------------------------------------------------------------------
>
>                 Key: HIVE-4406
>                 URL: https://issues.apache.org/jira/browse/HIVE-4406
>             Project: Hive
>          Issue Type: Bug
>          Components: HiveServer2
>            Reporter: Thejas M Nair
>            Assignee: Anandha L Ranganathan
>             Fix For: 0.12.0
>
>         Attachments: hive-4406.patch
>
>
> When the jdbc uri does not have a / or "/default" after the hostname:port, and the principal
is specified, it ends up launching HS2 in embedded mode.
> This is because the parsing of uri in such case does not end up extracting the hostname.
> eg . "jdbc:hive2://<host>:<port>;principal=<>." results HS2 embedded
mode getting used.
> "jdbc:hive2://<host>:<port>/;principal=<>" or "jdbc:hive2://<host>:<port>/default;principal=<>"
results in it connecting to the standalone hive server 2.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message