hive-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Tuong Truong (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HIVE-4338) Create Table fails after upgrade from 0.9 to 0.10
Date Mon, 29 Jul 2013 17:21:49 GMT

    [ https://issues.apache.org/jira/browse/HIVE-4338?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13722660#comment-13722660
] 

Tuong Truong commented on HIVE-4338:
------------------------------------

Can you kindly tell me if automatic upgrade is supported?    It's true that I pointed Hive
11 to a Hive 9 Derby metastore database.  However, based on the error we (originator of the
defect and myself) are seeing, it seems some sort of automatic upgrade is being done, but
not well.  Closing this Jira is fair if auto-upgrade is not supported...

Thanks...
                
> Create Table fails after upgrade from 0.9 to 0.10
> -------------------------------------------------
>
>                 Key: HIVE-4338
>                 URL: https://issues.apache.org/jira/browse/HIVE-4338
>             Project: Hive
>          Issue Type: Bug
>          Components: Database/Schema
>    Affects Versions: 0.10.0
>         Environment: Ubuntu  3.2.0-23-generic #36-Ubuntu on AMD
>            Reporter: Geula Vainappel
>
> I ran apt-get upgrade on a relatively old cdh installation. Many things were upgraded,
among them hadoop, hdfs and hive (from 0.9 to 0.10). After the upgrade, CREATE TABLE started
failing. I rebooted the machine, and it is still not working. The error I am receiving is:
> hive> create table ttt(line string);
> FAILED: Error in metadata: MetaException(message:javax.jdo.JDODataStoreException: Error(s)
were found while auto-creating/validating the datastore for classes. The errors are printed
in the log, and are attached to this exception.
> NestedThrowables:
> java.sql.SQLSyntaxErrorException: In an ALTER TABLE statement, the column 'IS_STOREDASSUBDIRECTORIES'
has been specified as NOT NULL and either the DEFAULT clause was not specified or was specified
as DEFAULT NULL.)
> FAILED: Execution Error, return code 1 from org.apache.hadoop.hive.ql.exec.DDLTask

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message