hive-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Brock Noland (JIRA)" <>
Subject [jira] [Resolved] (HIVE-4338) Create Table fails after upgrade from 0.9 to 0.10
Date Sat, 27 Jul 2013 17:33:48 GMT


Brock Noland resolved HIVE-4338.

    Resolution: Not A Problem

Agreed with Harsh J, it looks like the upgrade script was not run. Closing.
> Create Table fails after upgrade from 0.9 to 0.10
> -------------------------------------------------
>                 Key: HIVE-4338
>                 URL:
>             Project: Hive
>          Issue Type: Bug
>          Components: Database/Schema
>    Affects Versions: 0.10.0
>         Environment: Ubuntu  3.2.0-23-generic #36-Ubuntu on AMD
>            Reporter: Geula Vainappel
> I ran apt-get upgrade on a relatively old cdh installation. Many things were upgraded,
among them hadoop, hdfs and hive (from 0.9 to 0.10). After the upgrade, CREATE TABLE started
failing. I rebooted the machine, and it is still not working. The error I am receiving is:
> hive> create table ttt(line string);
> FAILED: Error in metadata: MetaException(message:javax.jdo.JDODataStoreException: Error(s)
were found while auto-creating/validating the datastore for classes. The errors are printed
in the log, and are attached to this exception.
> NestedThrowables:
> java.sql.SQLSyntaxErrorException: In an ALTER TABLE statement, the column 'IS_STOREDASSUBDIRECTORIES'
has been specified as NOT NULL and either the DEFAULT clause was not specified or was specified
> FAILED: Execution Error, return code 1 from org.apache.hadoop.hive.ql.exec.DDLTask

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see:

View raw message