hive-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Navis (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HIVE-4089) javax.jdo : jdo2-api dependency not in Maven Central
Date Thu, 04 Jul 2013 00:33:20 GMT

    [ https://issues.apache.org/jira/browse/HIVE-4089?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13699636#comment-13699636
] 

Navis commented on HIVE-4089:
-----------------------------

Yes I also think test cases in hive does not confirm the safety of upgrade but it confirms
APIs are compatible at least. We've some time till next release, so let's see what's happening
with 3.0.1 and rollback if it's not good. 

                
> javax.jdo : jdo2-api dependency not in Maven Central
> ----------------------------------------------------
>
>                 Key: HIVE-4089
>                 URL: https://issues.apache.org/jira/browse/HIVE-4089
>             Project: Hive
>          Issue Type: Bug
>            Reporter: Nitay Joffe
>            Assignee: Jarek Jarcec Cecho
>         Attachments: HIVE-4089.D11253.1.patch
>
>
> The latest open source hive release (0.10.0) depends on javax.jdo artifact jdo2-api version
2.3-ec. This version is not actually in maven central, which means everyone who uses hive
requires custom maven repository definitions which is discouraged by maven folks. I pinged
the javax.jdo guys about it and they recommended we upgrade to 3.0. See http://goo.gl/fAoRn
for the conversation.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message