hive-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Edward Capriolo (JIRA)" <>
Subject [jira] [Commented] (HIVE-4089) javax.jdo : jdo2-api dependency not in Maven Central
Date Wed, 03 Jul 2013 02:13:20 GMT


Edward Capriolo commented on HIVE-4089:

Going down to the eb version works as well. Passing tests is good but you REALLY need to try
this in combination with the pooling implementations and real databases, like mysql. In the
past tests with derby will pass but behind the scenes and it will not work with mysql, or
will not work correctly with the pooling implementation.
> javax.jdo : jdo2-api dependency not in Maven Central
> ----------------------------------------------------
>                 Key: HIVE-4089
>                 URL:
>             Project: Hive
>          Issue Type: Bug
>            Reporter: Nitay Joffe
>            Assignee: Jarek Jarcec Cecho
>         Attachments: HIVE-4089.D11253.1.patch
> The latest open source hive release (0.10.0) depends on javax.jdo artifact jdo2-api version
2.3-ec. This version is not actually in maven central, which means everyone who uses hive
requires custom maven repository definitions which is discouraged by maven folks. I pinged
the javax.jdo guys about it and they recommended we upgrade to 3.0. See
for the conversation.

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see:

View raw message