hive-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Navis (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HIVE-4598) Incorrect results when using subquery in multi table insert
Date Mon, 27 May 2013 07:04:20 GMT

    [ https://issues.apache.org/jira/browse/HIVE-4598?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13667500#comment-13667500
] 

Navis commented on HIVE-4598:
-----------------------------

I cannot reproduce the problem with simple query like 
{noformat}
FROM (select key,value from src order by key) a 
INSERT INTO TABLE srcpart PARTITION (ds='2008-04-08', hr='11') SELECT * WHERE key>=480

INSERT INTO TABLE srcpart PARTITION (ds='2008-04-09', hr='11') SELECT * WHERE key<=20;
{noformat}

Could you upload the query which made the problem with DDL?
                
> Incorrect results when using subquery in multi table insert
> -----------------------------------------------------------
>
>                 Key: HIVE-4598
>                 URL: https://issues.apache.org/jira/browse/HIVE-4598
>             Project: Hive
>          Issue Type: Bug
>          Components: Query Processor
>    Affects Versions: 0.10.0, 0.11.0
>            Reporter: Sebastian
>
> I'm using a multi table insert like this:
> FROM <x>
> INSERT INTO TABLE t PARTITION (type='x')
> SELECT * WHERE type='x'
> INSERT INTO TABLE t PARTITION (type='y')
> SELECT * WHERE type='y';
> Now when <x> is the name of a table, everything works as expected.
> However if I use a subquery as <x>, the query runs but it inserts all results from
the subquery into each partition, as if there were no "WHERE" clauses in the selects.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message