hive-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Carl Steinbach (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HIVE-4530) Enforce minmum ant version required in build script
Date Thu, 09 May 2013 20:37:16 GMT

    [ https://issues.apache.org/jira/browse/HIVE-4530?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13653160#comment-13653160
] 

Carl Steinbach commented on HIVE-4530:
--------------------------------------

+1.

In case anyone's curious 1.8.0 is the minimum version we can use because HCat's build depends
on the "skipexisting" attribute of the "get" task which was added in Ant v1.8.0. We also have
some code that depends on features added in 1.7.1.
                
> Enforce minmum ant version required in build script 
> ----------------------------------------------------
>
>                 Key: HIVE-4530
>                 URL: https://issues.apache.org/jira/browse/HIVE-4530
>             Project: Hive
>          Issue Type: Improvement
>          Components: Build Infrastructure
>            Reporter: Arup Malakar
>            Assignee: Arup Malakar
>            Priority: Minor
>             Fix For: 0.12.0
>
>         Attachments: HIVE-4530-trunk-0.patch
>
>
> I observed that hive doesn't build with older versions of ant (I tried with 1.6.5). It
would be a good idea to have the check in our build.xml. 

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message