hive-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Thejas M Nair (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HIVE-4406) Missing "/" or "/<dbname>" in hs2 jdbc uri switches mode to embedded mode
Date Wed, 24 Apr 2013 02:09:17 GMT

    [ https://issues.apache.org/jira/browse/HIVE-4406?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13639990#comment-13639990
] 

Thejas M Nair commented on HIVE-4406:
-------------------------------------

[~analog.sony] I am not working on this. Please go ahead with this. 
                
> Missing "/" or "/<dbname>" in hs2 jdbc uri switches mode to embedded mode
> -------------------------------------------------------------------------
>
>                 Key: HIVE-4406
>                 URL: https://issues.apache.org/jira/browse/HIVE-4406
>             Project: Hive
>          Issue Type: Bug
>          Components: HiveServer2
>            Reporter: Thejas M Nair
>            Assignee: Anandha L Ranganathan
>
> When the jdbc uri does not have a / or "/default" after the hostname:port, it ends up
launching HS2 in embedded mode.
> This is because the parsing of uri in such case does not end up extracting the hostname.
> eg . "jdbc:hive2://<host>:<port>" results HS2 embedded mode getting used.
> "jdbc:hive2://<host>:<port>/" or "jdbc:hive2://<host>:<port>/default"
results in it connecting to the standalone hive server 2.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message