hive-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Geula Vainappel (JIRA)" <j...@apache.org>
Subject [jira] [Created] (HIVE-4338) Create Table fails after upgrade from 0.9 to 0.10
Date Thu, 11 Apr 2013 10:15:18 GMT
Geula Vainappel created HIVE-4338:
-------------------------------------

             Summary: Create Table fails after upgrade from 0.9 to 0.10
                 Key: HIVE-4338
                 URL: https://issues.apache.org/jira/browse/HIVE-4338
             Project: Hive
          Issue Type: Bug
          Components: Database/Schema
    Affects Versions: 0.10.0
         Environment: Ubuntu  3.2.0-23-generic #36-Ubuntu on AMD
            Reporter: Geula Vainappel


I ran apt-get upgrade on a relatively old cdh installation. Many things were upgraded, among
them hadoop, hdfs and hive (from 0.9 to 0.10). After the upgrade, CREATE TABLE started failing.
I rebooted the machine, and it is still not working. The error I am receiving is:
hive> create table ttt(line string);
FAILED: Error in metadata: MetaException(message:javax.jdo.JDODataStoreException: Error(s)
were found while auto-creating/validating the datastore for classes. The errors are printed
in the log, and are attached to this exception.
NestedThrowables:
java.sql.SQLSyntaxErrorException: In an ALTER TABLE statement, the column 'IS_STOREDASSUBDIRECTORIES'
has been specified as NOT NULL and either the DEFAULT clause was not specified or was specified
as DEFAULT NULL.)
FAILED: Execution Error, return code 1 from org.apache.hadoop.hive.ql.exec.DDLTask


--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message