hive-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gunther Hagleitner (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HIVE-4187) QL build-grammar target fails after HIVE-4148
Date Mon, 18 Mar 2013 12:52:20 GMT

    [ https://issues.apache.org/jira/browse/HIVE-4187?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13605072#comment-13605072
] 

Gunther Hagleitner commented on HIVE-4187:
------------------------------------------

I've tracked down why antlr 2.7.7 is included. The antlr POM file is broken. It depends on
ST4 and stringtemplate which depend on antlr 2.7.7. Cute. Patch .1 resolves that by manually
pulling in antlrs transitive dependencies. With the patch applied:

{noformat}
% find . -name "*antlr*jar"
./build/dist/lib/antlr-runtime-3.4.jar
./build/ivy/lib/default/antlr-3.4.jar
./build/ivy/lib/default/antlr-runtime-3.4.jar
./build/ivy/lib/test/antlr-3.4.jar
./build/ivy/lib/test/antlr-runtime-3.4.jar
{noformat}

No idea where you are getting 3.0.1 from. But with 2.7.7 gone, that should at least fix the
build issue.

I like the single parent file/ivy inheritance approach. Is everyone onboard with that? Can
I open a new jira and start consolidating?


                
> QL build-grammar target fails after HIVE-4148
> ---------------------------------------------
>
>                 Key: HIVE-4187
>                 URL: https://issues.apache.org/jira/browse/HIVE-4187
>             Project: Hive
>          Issue Type: Bug
>          Components: Build Infrastructure
>            Reporter: Carl Steinbach
>            Assignee: Gunther Hagleitner
>            Priority: Critical
>


--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message