hive-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Owen O'Malley (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HIVE-4114) hive-metastore.jar depends on jdo2-api:jar:2.3-ec, which is missing in maven central
Date Wed, 13 Mar 2013 18:24:13 GMT

    [ https://issues.apache.org/jira/browse/HIVE-4114?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13601460#comment-13601460
] 

Owen O'Malley commented on HIVE-4114:
-------------------------------------

You'll also need to install the jdo2 jar in your maven repository:

{code}
download jdo2-api-2.3-ec.jar to your working directory
mvn install:install-file -DgroupId=javax.jdo -DartifactId=jdo2-api -Dversion=2.3-ec -Dpackaging=jar
-Dfile=jdo2-api-2.3-ec.jar
{code}

The new jdo jar is available from http://www.datanucleus.org/downloads/maven2/javax/jdo/jdo2-api/2.3-ec/jdo2-api-2.3-ec.jar

                
> hive-metastore.jar depends on jdo2-api:jar:2.3-ec, which is missing in maven central
> ------------------------------------------------------------------------------------
>
>                 Key: HIVE-4114
>                 URL: https://issues.apache.org/jira/browse/HIVE-4114
>             Project: Hive
>          Issue Type: Bug
>          Components: Build Infrastructure
>            Reporter: Gopal V
>            Priority: Trivial
>
> Adding hive-exec-0.10.0 to an independent pom.xml results in the following error
> {code}
>     Failed to retrieve javax.jdo:jdo2-api-2.3-ec
> Caused by: Could not find artifact javax.jdo:jdo2-api:jar:2.3-ec in central (http://repo1.maven.org/maven2)
> ...
> Path to dependency: 
> 	1) org.notmysock.hive:plan-viewer:jar:1.0-SNAPSHOT
> 	2) org.apache.hive:hive-exec:jar:0.10.0
> 	3) org.apache.hive:hive-metastore:jar:0.10.0
> 	4) javax.jdo:jdo2-api:jar:2.3-ec
> {code}
> From the best I could tell, in the hive build ant+ivy pulls this file from the datanucleus
repo
> http://www.datanucleus.org/downloads/maven2/javax/jdo/jdo2-api/2.3-ec/
> For completeness sake, the dependency needs to be pulled to maven central.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message