hive-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Phabricator (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HIVE-4025) Add reflect UDF for member method invocation of column
Date Tue, 19 Feb 2013 15:45:15 GMT

    [ https://issues.apache.org/jira/browse/HIVE-4025?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13581378#comment-13581378
] 

Phabricator commented on HIVE-4025:
-----------------------------------

brock has commented on the revision "HIVE-4025 [jira] Add reflect UDF for member method invocation
of column".

  Hi,

  Is there are a better name than reflect2? Perhaps reflect_obj, reflect_inst, or something
else?

  Brock

REVISION DETAIL
  https://reviews.facebook.net/D8601

To: JIRA, navis
Cc: njain, brock

                
> Add reflect UDF for member method invocation of column
> ------------------------------------------------------
>
>                 Key: HIVE-4025
>                 URL: https://issues.apache.org/jira/browse/HIVE-4025
>             Project: Hive
>          Issue Type: Improvement
>          Components: UDF
>            Reporter: Navis
>            Assignee: Navis
>            Priority: Trivial
>         Attachments: HIVE-4025.D8601.1.patch
>
>
> There are many useful non-static methods on type of primitive types. But current reflect
UDF cannot invoke those. For example,
> select reflect2(value, "replace", "val", "VALUE") from src;
> which replaces 'val' part of value column with 'VALUE'

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message