hive-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gang Tim Liu (JIRA)" <>
Subject [jira] [Commented] (HIVE-3627) eclipse misses library: javolution-@javolution-version@.jar
Date Fri, 02 Nov 2012 21:50:13 GMT


Gang Tim Liu commented on HIVE-3627:

HIVE-967 and HIVE-3433 introduce one missing library each for eclipse.

javolution<>.jar is introduce but mismatch @javolution-version@.
use "." but .classpath uses "."

<classpathentry kind="lib" path="build/ivy/lib/default/javolution-@javolution-version@.jar"/>

HIVE-3433. Implement CUBE and ROLLUP operators in Hive. (Ivan Gorbachev and Namit Jain via

introduces stringtemplate<>.jar but forgot to define stringtemplate.version.

<classpathentry kind="lib" path="build/ivy/lib/default/stringtemplate-@stringtemplate.version@.jar"/>

HIVE-967. Implement "show create table" (Feng Lu via kevinwilfong)
> eclipse misses library:  javolution-@javolution-version@.jar
> ------------------------------------------------------------
>                 Key: HIVE-3627
>                 URL:
>             Project: Hive
>          Issue Type: Bug
>          Components: Build Infrastructure
>            Reporter: Gang Tim Liu
>            Priority: Minor
>         Attachments: HIVE-3627.patch.1
> After checking out the latest trunk, build eclipse project:
> ant clean package eclipse-files
> Then, import project to eclipse, you will see the error:
> Description	Resource	Path	Location	Type
> Project 'hive-trunk-10-26' is missing required library: 'build/ivy/lib/default/javolution-@javolution-version@.jar'
hive-trunk-10-26		Build path	Build Path Problem

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see:

View raw message